Sant'Ambrogio NextGen - Getting started

What is NextGen?

NextGen is a mechanical, multi-code calculation software aimed to design pressure vessels and heat exchangers. Design can be carried out according to a growing number of standards, like ASME VIII Division 1 and 2, EN 13445 or AD2000.

The software is able to validate structural analysis of supports according to different codes and de-facto standards like NTC, WRC, UBC, ASCE, Moss, Bednar, etc.

Installing the software

Sant'Ambrogio provides a guide about installation, uninstallation and license management. If you need a copy of this guide, please contact our technical support at support@sant-ambrogio.it

Prerequisites

This guide assumes that the software is correctly installed and working. It is also assumed that the end user has a basic understanding of pressure vessels design criteria and knowledge of current calculation codes.

Project Browser

The first window shown after program startup is the so-called "Project Browser". Project Broser gives an overview on user's projects and can operate on them. The default location of user's projects is Documents\Sant'Ambrogio Projects

Project and Item definitions

A NextGen Project (.SPJ file extension) is a container that includes references to one or more Items (.SIT file extension). An Item includes multiple Components and represents a vessel or an heat exchanger; it contains all the required data (geometry, loads and so on) to validate them. User can take advantage of this hierarchy at his own will; usually, a project maps to an order.

For our "Classic Edition" software users, a single .SIT Item file contains all the components previously designed on different .IN input files.

Project Browser features

Main Project Browser's functions can be found on the top-left corner of the window:

These functions let the user work on common operations like creating, opening or deleting a project. Keep the mouse pointer on each button for a brief tool-tip about each button's function.

In the same windows, different buttons let the user work on Items:

Using these buttons, Items can be created, opened, renamed, copied or deleted.

» A detailed explanation about how to import an Item into a project can be found in the following article:

https://www.sant-ambrogio.it/en/how-to-import-an-item-file-sit/

Creating a new project

From "Projects" menu, select "Create new project":

Write the name of this project into the appropriate field, then click on "Create project" to save it. A message will confirm the operation.

"New item" button will then be enabled: click on it to create a new Item. The choice between Vessel or Heat Exchanger can be done in the pop-up menu that appears next. In this guide we're going to create a simple tank so click Vessel to continue. The following is the "Item Properties" window:

To proceed with a new Item creation it is mandatory to fill each field marked with a bold label. You can always recall the Item properties window later and fill or change any information about the current item. Note that all item properties are grouped by category (general, geometry, tests, etc.): switch between categories by clicking on the appropriate tab. Some tabs may be hidden, click on the arrow to show more tabs.

Fill with the Item name and select the desired calculation code, like "ASME VIII Division 1 Ed. 2015". Window will refresh to load additional, code-specific fields.

Switch to "Operating conditions" by clicking on the top tab to define calculation conditions for this Item:

Set temperature and pressure for internal pressure calculation (e.g. 200°C and 1.2 MPa) and, if needed, external pressure conditions (e.g., 200°C and 0.103 MPa by clicking on the "Vacuum" button). When external pressure calculation is not needed, leave 0 (zero) in the"External pressure" field.

It is also possibile to define a default joint efficiency value and corrosion allowances: these values will be applied on every new Component added later. It will always be possible to change them globally or on a per-component basis.

Once finished, click "Save" to begin working on the new Item. Main program window will be shown.

Workspace

Top toolbar and menu:

Give access to files management, databases (materials, flanges, bolts, gaskets, etc.) visualization, progam options and help functions.

Components toolbar:

Lets the user add one of the supported components, like cylinders, cones, heads etc. Buttons activation is contextual: elements are active only when they can be added in the model. Some component buttons are greyed since in the current context they can't be added: for instance, a nozzle can't be added to an empty model, since it needs a shell to be placed onto.

Components disabled by license restrictions are shown in red.

The active component toolbar:

Allows its edit or deletion, rebuilt of 3D model and visibility change. The "thermometer" button gives easy access to calculation conditions -- like temperatures and pressures -- also reachable via File > Item properties.

Other top toolbar buttons:

Allow to print current component or the whole item report, CAD sketch view, liquid level, wind and seism definition, load combinations and usage factor visualization.

Latest two functions are detailed in the following articles:

» Load combinations for structural analysis:

https://www.sant-ambrogio.it/en/nextgen-gestione-delle-combinazioni-di-carico-per-il-calcolo-strutturale-dei-supporti/

» Usage factor:

https://www.sant-ambrogio.it/en/usage-factor/

Two drop-down selectors can be found in the top-right area of the workspace:

These controls let you change the insert mode, switching between standard 3D design and "Desktop view" to design single, spare components and act on calculation code selection: by changing this value to a new calculation code, current item will be recalculated according to the latest selected code.

Left panels can show different information:

A hierarchical view of the item shows validation status (green for valid component, yellow for valid with warnings, red for not validated) of each component and let the user search within all Item components; the two remaining panels display item or currently selected component properties; these properties can also be modified rapidly from here.

Finally, the rightmost vertical toolbar let the user navigate the 3D model and change 3D visualization options.

Vessel design

Design starts from the main component, usually a cylindrical shell. Select "Cylinder" from the components toolbar and its editing window will appear:

Tip: "OK" button is disabled, since not every mandatory field is filled; like in "Item properties", also in this window mandatory fields are highlighted in bold. Hovering the "OK" button with mouse pointer highlights mandatory fields in bright red and moves to the first mandatory field not yet filled: this technique can be used to be guided through the whole input process.

To define a cylinder the only required values are material under "General" and length, diameter and thickness under "Geometry".

To select a material, click on "Database" button beside the material input text box: material database of current calculation code will show up.

Material database can be different from one calculation code to another: in this example, materials are those officially published by ASME in Section II part D for ASME VIII Division 1 use.

» Materials highlighted in yellow are "Custom", created by user. A step-by-step guide to create custom materials is available at the following link:

https://www.sant-ambrogio.it/en/create-custom-material/

The left panel in the Materials Database window shows the list of all available materials: this list can be sorted by clicking column headers or filtered via "Product forms", "Material types" or "Spec No" buttons.

Click on "Spec No" and type "516", then click on "Search" to find matching materials:

From the now filtered grid, select "SA-516 70" by double-clicking on it.

Under "Geometry", set cylinder dimensions:

Set length to 1000 mm, thickness to 10 mm and inside diameter to 500 mm. Outside diameter is automatically calculated.

After filling the last required field, component is automatically validated. Validation is in real time: this means that every time a value is changed, validation is re-run. Validation status is visible at-a-glance on the semaphore icon:

A green light means that the current component is fully validated without any issue. A yellow light means that there are warning about the validation: keep in mind that the warnings don't change the fact that -- according to the current calculation code -- the component is still valid. Designer should take a look at warnings and keep them in mind. A red light means that there are validation errors that must be checked and fixed.

Solving errors

When NextGen shows a number of errors keep in mind that they should be solved starting from the top of the list: often, following errors are a consequence of preceding ones and the get solved at the same time.

For example, the following images shows an insufficent thickness at internal pressure:

NextGen suggests to increase nominal thicknes to 2.57 mm instead of the current value of 2 mm. Once thickness is increased over the minimum required value, the following error also get fixed. In this case, all errors would be fixed since minimum required thickness at external pressure would be satisfied too.

Solving warnings

As stated before, warnings are different from errors: they don't have to be seen as something to get rid of to have a valid calculation. A calculation without errors that contains warnings is perfectly acceptable. When calculation report is printed, warnings can be omitted (while errors can't): they are shown to help user in getting the best design possible.

Some warnings can be easily removed by following what's written in them. For example, when a small opening is placed on an ASME VIII Div. 1 shell, the following message is shown:

Software suggests to disable opening validation because calculation code allows this at given reference. Once opening validation is skipped by ticking the appropriate checkbox, this warning disappears.

Some other warnings are not removeable: calculation is still valid and user should keep in mind what they say.

Messages

Sometimes one or more messages can be displayed (Messages tab with light blue background). In this case the importance is even lower compared to warnings. These are suggestions, coming from Sant'Ambrogio experience in the field and general good practice.

Adding component to the 3D model

Once "OK" button is enabled, the component is ready to be added to the whole model. Even if the validation shows some errors, the component can generally be added to the model: only geometric errors block this operation, because the 3D renderer can't draw a component that is geometrically imperfect. By clicking on "OK", a 3D rendering of component is generated and added to the model.

Upper toolbar buttons are enabled contextually, showing components that can be connected to the currently selected one.

Adding a head

It is now possible to proceed by adding a head to one side of the cylinder: from the upper toolbar, select the Torispherical Head icon. After clicking on it, NextGen asks at what side of cylinder this head should be connected to: click "OK" con confirm.

The component editing form for Torispherical Head will be shown: differently from previous component, the "OK" button is already clickable and the semaphore shows a green light: this happens because NextGen infers some characteristics from the connected component. In this case, material and inside diameter are copied from the cylinder. No other value is needed, hence the validation occurs.

The user can click "OK" to add this head to the model or change some properties in order to have a better design: for instance, heads can be thinner than cylinders and joint efficiency can be unitary if they are built in a single piece.

*Tip: joint efficiency set at Item level can lead to over conservative results on heads made from a single piece: it is a good practice to adopt a safe value at Item level as general efficiency, i.e. 0.85, then modify single components that can take advantage of unitary efficiency by acting on their own value under "Conditions".\ *

When the head is added to the model, it can be rapidly cloned on the opposite side by right-clicking on it and selecting "Copy Torispherical Head #1":

Head will then be copied to the other side of the cylinder.

From the same menu some actions contextual to the selected element can be choosen. For instance, it is possible to:

  • Insert an element between head and cylinder

  • Switch from one type of head to another

  • Create calculation report

These actions may be different from component to component.

After cloning the head, it is possible to proceed by adding a nozzle to the model.

Adding a nozzle

Select the main cylindrical shell, then from the upper toolbar select the "Nozzle" icon. The component editing window for Nozzle will be shown.

Set material to SA-106 B following the same procedure followed in shell material selection.

*Tip: besides browsing the whole database, it is possible to type in the material field the name of the desired material: a pop-up window will be displayed, allowing a faster material selection. Moreover, right-clicking on the same text input shows a list of recently used material, speeding up things a little more.\ *

Under "Geometry", click on "Pipes database" button and proceed by selecting a 4" STD pipe. Dimensions and undertolerance will be read from database, saving time while designing.

Under "Welds", set nozzle to wall fillet to 6 mm. Some properties in NextGen have a contextual help icon:

By clicking on it, an explanation about the current property is shown; in this case, a clarification about how leg fillet is measured.

Finally, under "Position", set the distance from the shell border. For simplicity, click on "Center" to position the nozzle at 500 mm. Input is now complete for the component to be validated; the validation will start automatically.

Before clicking "OK", take a look at the bottom-left corner panel:

Validation results are listed here: since the current component is a nozzle, both validations as cylinder and opening are shown. Then click "OK" to add the nozzle to your item.

Adding a flange

As final component, add a standard flange on top of nozzle just created: right-click on the nozzle, then select "Add standard flange" > "Welding neck" from the contextual menu:

In the following window, select the class for the flange, e.g. 150.

Component editing window for this flange will open: set material to SA-105. Hovering the disabled "OK" button shows that bolts and gasket data are missing: since this is a peripheral standard flange, this validation can be omitted; to achieve this, check "Disable bolts and gasket validation" under "Standard flange" tab.

Flange will then be validated with a warning. Read the warning relative to the just disabled validation, then click "OK" to add the flange to the model.

Adding more components

NextGen interface is designed to show a consistent interface across different components. Properties are listed in the clearest way possible and once familiar with simple components like shells, the user will be able to follow the design of a more complex component without much trouble.

Contextual help buttons are there to clarify any doubt regarding specific properties.

The definition of the vessel with more components can proceed linearly, following the same procedure for each additional component.

Setting a liquid level

A common operation in pressure vessels design is the definition of an hydrostatic pressure in operating conditions. Using NextGen, this can be easily done by selecting a body component (for an horizontal vessel the cylindrical shell; for a vertical vessel, the component where liquid level lies), then clicking on the glass icon in the top toolbar.

Liquid name, height and density must then be set. The liquid level is relative to the lowest point of the current component.

After clicking "OK", the liquid level is rendered as a blue surface:

Some remarks:

  • In test condition, liquid level is always automatically calculated filling the whole vessel with water.

  • In operating conditions, every component in contact with the liquid will have an hydrostatic pressure automatically calculated. The value is shown -- and can be overwritten -- in "General", "Overpressure due to static head".

Printing

A report for a single component or the whole item can be created any time.

The single component report is particularly helpful when the reason behind a calculation error must be understood: NextGen produces a complete report, with all calculation done by the software, printing every formula used and therefore allowing a manual verification of calculation.

To produce a complete item report, click on the pile of books icon in the top toolbar:

In the following window it is possible to include, exclude or reorder components, or customize the printing options. For advanced options click on the "Options" button in the bottom of the window. Once the report is set-up, click on "Report" to start its creation.

Calculation report is easily browsable via integrated viewer or exported in both .PDF and Word .DOCX formats.

Main item properties

Item properties are always available by selecting "File" > "Item properties". Here are some of the most important options:

Please note that some sections may not be visible: use the arrows to jump through tabs.

General

In this section some default values can be choosen, like flange reference standard, bolts or default set of materials. In the case of calculations according to ASME, reference publication -- metric or customary -- and input units system can be set here.

Geometry

Set item orientation to vertical in this section.

Test

Under "Test" it is possible to choose between different test configurations (none, hydrostatic test, pneumatic test or a combination), set a manual test pressure and specify test condition options. For ASME VIII Division 1 a complete hydrostatic test can be set here: internal pressure calculation will be repeated using test pressure and an allowable value based on the yield strength of the material.

Location, seism, wind

These options allows to set geographical position of the item and options pertinent to seism and wind according to codes like ASCE, Eurocode, UBC, NTC.

Reporting

In this section, information printed on the upper-right corner of the report can be set.

Fatigue

Only for EN13445, this section allows the definition of a fatigue analysis on current vessel.

Main program options

From "Tools" > "Options" it is possible to set different program options. Here's a recap:

General options

Under "General" it is possible to set working directories for the software, especially useful in a network environment where files and custom database must be shared between different users.

Communications

If a proxy is needed to access the internet, it can be set from here.

Reporting

Default reporting options can be set here. Each item can use these options or override them with a different, per-item specific set. Options include which summary pages must be printed and other options can be set by selecting a different sub-section from tabs placed on the left: validation warnings can be excluded from here, output units changed and report header plus logo set.

Components

Under "Components" a checkbox labeled "Enable geometric relationships between adjacent components" can be found: NextGen takes care of relative components resizing, keeping their dimensions syncronized. When this behaviour is unwanted, it is possible to use this option.

» A detailed explanation of this function is available at the following link:

https://www.sant-ambrogio.it/en/how-to-manage-geometric-relationships-between-components-nextgen/

In the same section, an option to define different pressures between adjacent components is available: check this if you want to modify the pressure value from within a component editing window.

Ask for help

NextGen has an integrated help request form, called "Ask for support": this form can be opened from the button in the topmost toolbar.

» A detailed explanation of this function is available at the following link:

https://www.sant-ambrogio.it/en/how-to-ask-for-technical-support/

Additional resources

Tecnical articles section on Sant'Ambrogio website is constantly updated. Here's a list of useful resources; full list of support articles is available at the following link:

https://www.sant-ambrogio.it/en/category/support/

» Using the Heat Exchanger Wizard

https://www.sant-ambrogio.it/en/heat-exchanger-wizard/

» Validate an attachment according to WRC 107, WRC 537 or WRC 297 bulletins

https://www.sant-ambrogio.it/en/how-to-validate-an-attachment-nozzle-or-support-according-to-wrc-107-wrc-537-o-wrc-297/

» Create additional components (design mode similar to Sant'Ambrogio Classic Edition software):

https://www.sant-ambrogio.it/en/how-to-create-an-additional-component/


Author: Matteo Bagattini
Permalink: KB594537
Published on: 01 Jan 2017


Feedback